Bug des pages

Accueil > Assistance > Support > Rapport de bug > Bug des pages
U

Utilisateur v3, Il y a 7 ans et 5 mois

Bonjour! c'est urgent:


  • des sous pages ont été supprimées, cependant le site ne les considère pas comme telle, résultat on ne peut pas supprimer les pages!

  • Le site pense que la page Accueil a une sous-page alors que ce n'est pas le cas! de même pour Twitch TV/youtube

  • Alors que dans affichage des pages tout semble normal, l'organisation des pages+ sous-page a totalement été foutu en l'air et impossible d'y remédier car d'après le site tout est normal!!



Ce bug est apparu pendant une restructuration du site lorsque j'ai supprimé la sous page twitch TV de Twitch TV/Youtube, il y a environ 30 min. On a essayé de refaire les parents de chaque page, rien n'y fais ça ne fait que empirer encore plus avant seul 2-3 catégories étaient touchés maintenant c'est l'ensemble du site; à ne rien y comprendre!

http://whitesoulsgaming.guildi.com/fr/accueil

Voilà, j'espère avoir une solution le plus vite possible car le site est totalement désorganisé :/

Site internet :
#5 Guildi - https://guildi.com

U

Utilisateur v3, Il y a 7 ans et 5 mois

désolé du double post mais si possible on peut pas avoir un back du site à l'heure suivante ?  : 18h40

Car là je vois pas ce qui a pu le faire bug. Il pense que les sous pages existent ( il y a bien un menu pour dérouler pour accueil mais il n'y a pas de sous pages....) alors qu'il n'y en a JAMAIS eu !!! 


Par ailleurs : ce bug est par rapport au site => tous les membres voient le bug

U

Utilisateur v3, Il y a 7 ans et 5 mois

Bonsoir Thunderlight,

Ton site a l'air offline, je n'arrive pas à y accéder.

U

Utilisateur v3, Il y a 7 ans et 5 mois

heu bizarre il était online il y a 2 minutes ?! Je n'y suis même pas retourné o_O

Alors là c'est du délire... quelqu'un m'a dis qu'on pouvait plus y accéder je pensais que c'était vous qui étiez entrain de regarder mais si il est offline sans que vous ayez fais quoique ce soit je sais pas ce qui se passe ...

U

Utilisateur v3, Il y a 7 ans et 5 mois

Il est probable que ton site se soit complètement bugué suite à une manipulation.
Quoi qu'il en soit je ne m'y connais pas assez au niveau technique pour te fournir une réponse digne de ce nom.

U

Utilisateur v3, Il y a 7 ans et 5 mois

 Ok bon au moins il est shut down donc il va rester comme il est là actuellement il va pas empirer xD

Sinon, je vais tenter de décrire un max le bug : on a voulu regrouper plusieurs pages pour rendre plus lisible le site. On a donc supprimé certaines pages : la page twitch. Cependant, ça a commencé a bug juste après : il marquait dans le sommaire des sous-pages qu'elle existait encore, or ce n'était pas le cas, à partir de ce moment, il y a eu l'apparition de sous-pages "invisibles" sur quasiment l'ensemble de nos pages, puis il y a eu le bug des pages qui se lient entre elles alors que le panneau d''admin affirme que rien ne se passe .

après j'ai fais un screen pour expliquer vite fais ce qu'il s'est passé: sur la gauche on voit la liste des pages ainsi que de la hiérarchie or ce n'est pas du tout la même que celle affiché sur le panneau.

Voilà, j'espère juste que vous allez pouvoir nous aider, pas envie de refaire tout le site :'(

djidi

djidi, Il y a 7 ans et 5 mois

Salut,

Merci pour les informations, je vais voir ce qui a pu provoquer ca.
Pour le site inaccessible, cela est du à deux pages qui redirigent en boucle l'une vers l'autre (Dofus et accueil Dofus).

J'ai corrigé les deux problèmes.
Pour les positions des pages, j'ai fait un reset complet : les positions sont donc désormais correctes mais il faudra replacer les pages dans les bons sous-menus (toutes les pages ont été mis au même niveau dans l'arborescence) et refaire les redirections qu'il y avait.

U

Utilisateur v3, Il y a 7 ans et 5 mois

Bonjour et merci pour la correction des bugs: les sous-pages invisibles sont partis et au moins même ci rien n'est rangé c'est lisible, cependant il n'y a pas 2 sans 3 (décidément...) et quand j'ai voulu test de mettre une page en sous page à une autre, ça m'a marqué

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.More information about this error may be available in the server error log.

http://whitesoulsgaming.guildi.com/fr/m/forum

le site ( le serveur ? :O) est down


x_X

djidi

djidi, Il y a 7 ans et 5 mois

C'était à cause d'une URL mal formée : l'une des page avait un espace dans le champ pour l'URL ce qui a fait planter le système des URLs.

C'est corrigé et je rajouterais un test pour bloquer/remplacer les URLs incorrectes.

U

Utilisateur v3, Il y a 7 ans et 5 mois

 Bonjour et merci, le site marche et il ne crash plus.
Cependant, il reste encore un bug ...certaines pages sont en sous-pages pourtant elles restent affichées (il n'y a pas de menu déroulant) comme si elles ne les étaient pas.... Mais bon le site marche c'est déjà ça :)


Edit: screenshot :

U

Utilisateur v3, Il y a 7 ans et 5 mois

Dsl du double post,  certaines pages se sont corrigées naturellement, d'autres restent toujours buguées, Notamment la page mère guild wars2 et les sous pages accueil gw2, nouveautés, etc... ( comme indiqué sur le screen)

Edit: en fait même les nouvelles pages que l'on crée "bug", lors que l'on met des sous-pages, le panneau d'admin affirme qu' elles ont des sous-pages, mais sur le site les sous-pages n'apparaissent pas dans un menu déroulant mais à côté comme si elles étaient raccordées à accueil...

U

Utilisateur v3, Il y a 7 ans et 5 mois

 on a trouvé une solution ( refaire les pages parentes)

 Merci pour avoir réparé le site, on tachera d'être plus prudent et de moins faire les fous la prochaine fois :D

U

Utilisateur v3, Il y a 7 ans et 3 mois

Bonjour bonjour ! :D


Je suis tout nouveau sur la création de guilde et j'ai rencontré le même problème, le site pense qu'il y a des sous groupes alors qu'il n'y a rien du tout.

Ce problème a eu lieu dans la soirée, je modifiais les différentes pages quand elles ont complètement bugué. J'ai essayé de supprimer des pages, de les changer de "place" de changer les titres mais rien à faire. J'ai donc tout supprimé pour voir si ça fonctionnait mais rien à faire ça veut pas bouger ^^

Que faut-il faire pour gérer ce problème?

Voici l'adresse du site ;)   http://arrancars-wakfu.guildi.com/fr/accueil

Merciiii ! :D

djidi

djidi, Il y a 7 ans et 3 mois

Salut,

Les positions de tes pages ont été actualisées.

U

Utilisateur v3, Il y a 7 ans et 2 mois

Salut salut ! :D

Aha ! PERFECT, merci beaucoup Djidi :D
Et tu peux me dire d'où venait l'erreur? Peut être que j'ai fais une fausse manip' qui a bloqué la page nan?

djidi

djidi, Il y a 7 ans et 2 mois

C'est un problème sur le calcul des positions des pages (lors des créations ou déplacements).
Ce sera corrigé dans la prochaine MAJ et ne devrait plus se reproduire.

Status Cloturé

djidi, Il y a 7 ans et 5 mois

Utilisation des données

Nos partenaires et nous-mêmes utilisons différentes technologies, telles que les cookies, pour personnaliser les contenus et les publicités, proposer des fonctionnalités sur les réseaux sociaux et analyser le trafic. Utilisez les boutons pour donner votre accord ou refuser.